今天我们继续上一次的路由协议,实际上在CCNA考点中,这一块不要求深入理解,但是必须知道,另外呢,有一些知识点和可以贯穿到后续的重点OSPF的。

首先回忆一下,RIP和EIGRP都属于distance vector类型的,都属于IGP,都属于谣言传播。接下来我们了解一下详细情况。

RIP 全名是 Routing Information Protocol,是IEEE的标准,通过 distance vector来决定同类路由协议哪个优先级更高。每一个路由器算一跳也就是一个HOP,最多最多15跳,也就是说这个协议只能用在小型系统中,一旦一个链路超过15个路由器就无法到达了。

RIP目前有三个版本,

IPv4使用RIPv1和RIPv2

IPv6使用RIPng RIP next generation

RIP有两种信息类型,一种是Request,向同样开了RIP协议的自己邻居索要他们的路由信息,另外一种是Response,就是给同样开了RIP协议的自己邻居发送自己的路由信息

其中RIPv1只能宣传或者说使用有类路由,即A类 255.0.0.0,B类 255.255.0.0,C类 255.255.255.0,它并不支持CIDR和VLSM,系统的给自己的邻居发信息时是省略了子网掩码的,比如只有10.0.0.0,172.16.0.0,192.168.1.0。另外刚才提到的两种信息类型是通过广播255.255.255.255发出去的。

RIPv2就是今天要学的重点,支持VLSM,CIDR,在向邻居发信息时候包含子网掩码,另外通过组播来发送信息而不是广播。

默认情况下,RIP信息每30秒更新一次

组播和广播的区别,就是组播只给组内发,广播给所有的发。

RIPv2用的组播地址是224.0.0.9

那么接下来就是配置方法,首先进入路由器配置模式 conf t

首先进入rip配置

router rip

接下来是设置版本2,不设置就进去版本1了,那么CIDR,VLSM等无法

version 2

再下来这个命令也必须要设置,不然的话路由广播宣传仍然是有类路由,

no auto-summary

以上两条必须设置,

接下来有两种设置方法,第一种就是设置成有类,第二种是设置成无类的,但是不管设置成哪种,都会被路由器转换成有类的,但是实际上路由器会自动检测实际的路由,并且将实际上的路由广播给邻居(不是你输入的10.0.0.0,而是实际的10.0.12.0/30 和 10.0.13.0/30),另外注意这里不需要输入子网掩码

network 10.0.0.0

network 172.16.1.0

可以理解为network命令并不是让路由器把你输入的IP路由发送给邻居,而是让路由器把自己符合你输入范围的IP路由发送给邻居。

这里有一种特殊情况,比如某端口连接的是终端,实际上对路由信息没兴趣,但是路由器开启了RIP后会持续给该端口发送路由信息,所以为了避免该情况,可以关闭该端口RIP广播或者组播。命令如下,

passive-interface g2/0

后面学到的EIGRP也有该命令

另外一个命令也很实用,比如某一个路由器连接到了互联网,并且配置了静态路由如下所示,所有的traffice都会从203.0.113.2出去

ip route 0.0.0.0 0.0.0.0 203.0.113.2

那么其他路有如何知道该信息呢?只需要在刚才那个路由器上配置命令

default-information originate

另外一个常用的命令可以查看路由协议是

show ip protocols

可以看到常见的参数,比如版本,比如之前设置的参数,其中maximum path是默认的4,这个值是ECMP 即equal cost multi path,该值可以更改,进入到路由设定后可以更改,

maximum-paths ?

后面数字可以从1到32

最下面的distance就是AD值,也可以更改,用于不同路由协议的优先级比较,还是进入到路由设定后

distance ?

数字可以从1到255,

以上两个命令在EIGRP中也适用

另外再提一下,RIP是只考虑hop的不考虑网速等其他要素,因此如下图所示,F口和G口因为hop相同所以负载平衡。

另外一个基于distance vector的协议是EIGRP

EIGRP 全程是 enhence interier gateway routing protocol

该协议是思科专有协议,不过已经发布了,所以其他厂家也可以使用

该协议比RIP要高级,速度上更快,并且没有15个hop的限制,发送给邻居信息时候用的是组播发送到 224.0.0.10

EIGRP是IGP中唯一一种可以实现unequal cost load balancing的协议,不过改设置需要手动更改,不改的话和RIP一样是4个path的ECMP。

具体设置如下,还是进入到config t

首先设置路由协议为eigrp,后面这个数字1是autonomous system,可以任意更改,但是不同路由器的数字必须一样

router eigrp 1

下面的和之前的RIP一样,不开的话不支持CIDR和VLSM

no auto-summary

下面的和之前的命令一样,用于将连接到终端的端口设置成不发送路由信息

passive-interface g2/0

下面的两种模式都可以,第一条和之前RIPv2是一样的原理

network 10.0.0.0

第二种就是新的方式,设置IP地址以及通配符掩码或者通俗一点反掩码,简单的可以理解为和子网掩码相反的东西,例如下面例子其实对应的就是子网掩码中的 255.255.255.240

network 172.16.1.0 0.0.0.15

而在show ip protocols 中可以看到很多参数

这里可以看到几个关键点,其中K值用来计算 metric的,有一个很复杂的公式,如下图所示,其中K1和K3默认是1,其他是0,简单可以记住就是bandwidth+delay,其中bandwidth用最慢的link,而delay需要叠加所有links中的delay

Router-ID就是一个ID值,可以手动设置,也可以使用默认,按照优先级顺序是手动配置,最高Loopback IP,最高物理接口IP

手动配置,命令是

eigrp route-id ?

后面的问号跟着一个IP地址格式就可以比如1.1.1.1

最高的loopback IP地址(也可以手动配置)

进入到conf t

int loopback

最高的的物理接口IP地址

下图可以看到D代表EIGRP,其中这两个数字要注意下,前面的就是AD值,默认是90当然也可以更改,后面的是metric值,使用复杂共识计算的,当然也可以手动更改参数导致结果变更。

接下来讲几个EIGRP的参数

我们可以看下图

这里引入概念

Feasible Distance:该值简称FD,也就是某路由到达某目的地的metric值,如下图中红色

Reported Distance:该值简称RD,也就是某路由的邻居到达某目的地的metric值,如下图中蓝色

Successor:就是路由到达目的地的最佳路由(最低的metric路线)

Feasible Successor:就是能够符合 feasibility condition的备选路由(不是最好的路由)

其中feasible condition:假如该路线的RD是低于successor的FD就满足feasible condition

还是看上图中,如果在R1中打命令

show ip eigrp topology,

可以看到如下图所示,左侧是RD,右侧是FD,对应R2和R3

换成不同颜色表示则如下图

这个例子来说,通过R3的RD值是28416要低于通过R2的FD值28672,所以通过R3的路由是feasible successor

之前我们说过EIGRP是IGP里唯一一个可以实现unequal cost 负载平衡的,接下来我们可以看一下,当在路由器输入show ip protocols后,

我们可以得到一大堆参数,其中这个 metric variance 是1,1是默认设置,代表着只能ECMP,所以想实现之前我们说的功能必须更改该参数,还是进入到路由设置后

variance ?

其中后面数字可以使1到128

假设设置成了2,那么路由器会把successor的FD值乘以该参数,这时候feasiable successor的FD值如果小于该值,则被选中用于unequal cost 负载平衡。

还是上面的例子,比如设置成了2,那么那么28672*2=57344,该值大于通过R3的30976,因此R3这条路径被选中。

切记只有feasible successor才有可能被选中,不是的话根本不用计算这个乘以多少多少,压根没有资格被选。

这节课的实验部分可以多练习几下,不然不熟悉。

YouTube player
YouTube player

——————————————————-分隔符——————————————————————-

——————————————————-分隔符——————————————————————-

——————————————————-分隔符——————————————————————-

——————————————————-分隔符——————————————————————-

——————————————————-分隔符——————————————————————-

——————————————————-分隔符——————————————————————-

——————————————————-分隔符——————————————————————-

——————————————————-分隔符——————————————————————-

——————————————————-分隔符——————————————————————-

——————————————————-分隔符——————————————————————-

Day 25 Anki Flashcard下载:https://drive.google.com/file/d/1gwAyAGbNGLo03xS_3nsf13-tAIbgxrJy/view?usp=sharing

Day 25 Anki Extra Flashcard下载:https://drive.google.com/file/d/1qD5N3C2A12GMUWOrzqe39GjIvKMzlVeZ/view?usp=sharing

Day 25 Cisco Packet Tracer 练习题下载:https://drive.google.com/file/d/1oe_uIfCB9jQABtx2SEoTkFQGgX1s2KE6/view?usp=sharing

Day 25 Cisco Packet Tracer 练习题完成下载:https://drive.google.com/file/d/1jaiEzTfwxs0GFNC1jgxmon_clZ1r-8Lt/view?usp=sharing


Chao

一个三天打鱼两天晒网的博主 拖延症严重患者 干啥啥不行,学啥啥不会

0 条评论

发表回复

Avatar placeholder